The T-Mobile Vibrant, the carriers variant of the Galaxy S, has officially been dropped from CyanogenMod. The Vibrant is no longer supported due to an issue with E911. Unfortunately, the device will remain unsupported until at least Samsung release the source code to correct the issue, at which time the CyanogenMod team will re-evaluate support for the Vibrant.

We are no longer supporting the Vibrant due to the inability to dial 911. We consider the issues related to this unresolvable without source code from Samsung related to the Radio interface layer and its interactions with the Audio layers and have taken the decision to no longer support this. We apologize for the inconvenience and strongly suggest that Vibrant users use a Samsung ROM due to the 911 issues with any ROMs based on open source code.
-SGS Team/Team Hacksung/Teamdouche

This is a rather serious issue, which you should pay close attention to. If you are running CM you should flash another Samsung ROM immediately. Not being able to properly use 911 is a rick you should not be wiling to take. When the time comes and you need help, the last thing you want is a device where the 911 operator cannot hear you.

Via: CyanogenMod